|orangepi0] [synchro NTP ] et timezone

Discussions autour des probllématiques réseau
jml
Messages : 98
Inscription : 29 janv. 2018, 09:47
Localisation : Biévres (91570)

|orangepi0] [synchro NTP ] et timezone

Message par jml » 15 févr. 2018, 21:02

Bonjour,

Un petite histoire de timezone à priori ?

Ma config ....

ansible@srv-orangepi0-2:~$ uname -a
Linux srv-orangepi0-2 4.11.12-sun8i #2 SMP Wed Nov 22 13:50:32 CET 2017 armv7l GNU/Linux

ansible@srv-orangepi0-2:~$ cat /etc/debian_version
9.3

J'ai un équipement bien synchronisé sur son serveur NTP, puisque ...
ansible@srv-orangepi0-2:~$ sudo ntpq
ntpq> peers
remote refid st t when poll reach delay offset jitter
==============================================================================
srv-ntp-1-ntp.m .STEP. 16 u - 64 0 0.000 0.000 0.000
srv-ntp-2-ntp.m .STEP. 16 u - 64 0 0.000 0.000 0.000
srv-ntp-3-ntp.m 134.214.100.6 3 u 139 64 174 1.130 156665. 102562.

ansible@srv-orangepi0-2:~$ LANG=C date
Thu Feb 15 19:43:36 UTC 2018

alors qu'en fait il est .....
ansible@L318691:~/git/ansible-jml.git/sources$ LANG=C date
Thu Feb 15 20:43:24 CET 2018

Il y a donc bien une erreur de 1 heure, mais
ansible@srv-orangepi0-2:~$ dpkg -l |grep tz
ii tzdata 2017c-0+deb9u1 all time zone and daylight-saving time data
...
et ..
ansible@srv-orangepi0-2:~$ cat /etc/timezone
Europe/Paris

Aurais-je oublié un point ?....

Je constate cependant 1 point ....
ansible@srv-orangepi0-2:~$ sudo tcpdump -i eth-ntp port ntp -vvvv
tcpdump: listening on eth-ntp, link-type EN10MB (Ethernet), capture size 262144 bytes

19:45:30.566443 IP (tos 0xb8, ttl 64, id 37062, offset 0, flags [DF], proto UDP (17), length 76)
srv-orangepi0-2-ntp.mydomain1.noip.org.ntp > srv-ntp-2-ntp.mydomain1.noip.org.ntp: [bad udp cksum 0x9185 -> 0x9edd!] NTPv4, length 48
Client, Leap indicator: clock unsynchronized (192), Stratum 4 (secondary reference), poll 7 (128s), precision -19
Root Delay: 0.031326, Root dispersion: 0.448196, Reference-ID: srv-ntp-3-ntp.mydomain1.noip.org
Reference Timestamp: 3727712247.238499755 (2018/02/15 19:37:27)
Originator Timestamp: 0.000000000
Receive Timestamp: 0.000000000
Transmit Timestamp: 3727712730.566284297 (2018/02/15 19:45:30)
Originator - Receive Timestamp: 0.000000000
Originator - Transmit Timestamp: 3727712730.566284297 (2018/02/15 19:45:30)
19:45:57.567049 IP (tos 0xb8, ttl 64, id 64348, offset 0, flags [DF], proto UDP (17), length 76)
srv-orangepi0-2-ntp.mydomain1.noip.org.ntp > srv-ntp-3-ntp.mydomain1.noip.org.ntp: [bad udp cksum 0x917b -> 0x30de!] NTPv4, length 48
Client, Leap indicator: clock unsynchronized (192), Stratum 4 (secondary reference), poll 6 (64s), precision -19
Root Delay: 0.031326, Root dispersion: 0.448593, Reference-ID: srv-ntp-3-ntp.mydomain1.noip.org
Reference Timestamp: 3727712247.238499755 (2018/02/15 19:37:27)
Originator Timestamp: 3727712574.232656001 (2018/02/15 19:42:54)
Receive Timestamp: 3727712417.567267926 (2018/02/15 19:40:17)
Transmit Timestamp: 3727712757.566258742 (2018/02/15 19:45:57)
Originator - Receive Timestamp: -156.665388075
Originator - Transmit Timestamp: +183.333602740


Pas bon ca (!) les bad checksun .....

Comment cela se fait il ??

Une idée peut être du coté du dhcp , sachant que cet équipement est en DHCP sur cette interface
sudo tcpdump -i eth-ntp port bootpc or port bootps -vvv....

srv-cubietruck-1-ntp.mydomain1.noip.org.bootpc > 255.255.255.255.bootps: [udp sum ok] BOOTP/DHCP, Request from 02:00:00:0f:01:07 (oui Unknown), len
gth 311, xid 0xe45f6b5d, secs 270, Flags [none] (0x0000)
Client-IP srv-cubietruck-1-ntp.mydomain1.noip.org
Client-Ethernet-Address 02:00:00:0f:01:07 (oui Unknown)
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: Request
Lease-Time Option 51, length 4: 600
Hostname Option 12, length 24: "srv-cubietruck-1-eth-ntp"
Parameter-Request Option 55, length 7:
Subnet-Mask, Hostname, MTU, NTP
Time-Zone, TZ-Name, BR
Client-ID Option 61, length 24: hardware-type 115, 72:76:2d:63:75:62:69:65:74:72:75:63:6b:2d:31:2d:65:74:68:2d:6e:74:70
END Option 255, length 0

Pour la demande, donc en effet les éléments Time-Zone, TZ-Name sont demandés.

et le serveur réponds....
19:56:00.959392 IP (tos 0x0, ttl 64, id 720, offset 0, flags [DF], proto UDP (17), length 347)
solo-ntp.mydomain1.noip.org.bootps > srv-orangepi0-2-ntp.mydomain1.noip.org.bootpc: [udp sum ok] BOOTP/DHCP, Reply, length 319, xid 0x86f0b27b, Fla
gs [none] (0x0000)
Client-IP srv-orangepi0-2-ntp.mydomain1.noip.org
Your-IP srv-orangepi0-2-ntp.mydomain1.noip.org
Client-Ethernet-Address 02:00:00:19:00:07 (oui Unknown)
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: ACK
Server-ID Option 54, length 4: solo-ntp.mydomain1.noip.org
Lease-Time Option 51, length 4: 600
Subnet-Mask Option 1, length 4: 255.255.255.0
BR Option 28, length 4: 192.168.7.255
Time-Zone Option 2, length 4: 1
Hostname Option 12, length 19: "srv-orangepi0-2-ntp"
Netbios-Name-Server Option 44, length 4: srv-wins-2-service.mydomain1.noip.org
MTU Option 26, length 2: 1500
NTP Option 42, length 12: srv-ntp-1-ntp.mydomain1.noip.org,srv-ntp-2-ntp.mydomain1.noip.org,srv-ntp-3-ntp.mydomain1.noip.org
END Option 255, length 0



????

jlm
Messages : 3
Inscription : 01 août 2018, 10:59

Re: |orangepi0] [synchro NTP ] et timezone

Message par jlm » 01 août 2018, 11:09

Hello
la derniere fois que j'ai eu ce genre de pb c'etait dans une VM sur mon srv chez Online. Ai-je raté qq ch dans la conf de l'hyperviseur pour que la VM n'herite pas des env de localisation: j'avais aussi des incidents de caracteres sous vi comme si pas en utf
dpkg-reconfigure tzdata
dpkg-reconfigure locales , c'est revenu dans l'ordre. pas cherché plus loin.

Répondre